flutter_aws_rest 0.0.1

  • README.md
  • Installing
  • Versions
  • 37

flutter_aws_rest #

A new Flutter package as AWS Client

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  flutter_aws_rest: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:flutter_aws_rest/flutter_aws_rest.dart';
Version Uploaded Documentation Archive
0.2.0 Oct 19, 2018 Go to the documentation of flutter_aws_rest 0.2.0 Download flutter_aws_rest 0.2.0 archive
0.0.1 Oct 19, 2018 Go to the documentation of flutter_aws_rest 0.0.1 Download flutter_aws_rest 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on May 8, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.0
  • pana: 0.12.15
  • Flutter: 1.5.8


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Fix lib/flutter_aws_rest.dart. (-25 points)

Analysis of lib/flutter_aws_rest.dart failed with 1 error:

line 28 col 21: Undefined class 'Logger'.

Document public APIs. (-1 points)

77 out of 77 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/cryptoutil.dart. (-1.49 points)

Analysis of lib/src/cryptoutil.dart reported 3 hints:

line 227 col 9: Name non-constant identifiers using lowerCamelCase.

line 308 col 7: The class '_MD5' isn't used.

line 386 col 7: The class '_SHA1' isn't used.

Format lib/src/request_payload.dart.

Run flutter format to format lib/src/request_payload.dart.

Format lib/src/request_signer.dart.

Run flutter format to format lib/src/request_signer.dart.

Format lib/src/s3_bucket_api.dart.

Run flutter format to format lib/src/s3_bucket_api.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_aws_rest.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
crypto ^2.0.6 2.0.6
flutter 0.0.0
intl ^0.15.7 0.15.8
xml ^3.2.3 3.4.1
Transitive dependencies
charcode 1.1.2
collection 1.14.11
convert 2.1.1
meta 1.1.6 1.1.7
path 1.6.2
petitparser 2.2.1
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies