flutter_aws_rest 0.2.0

  • Readme
  • Changelog
  • Installing
  • 16

flutter_aws_rest #

A new Flutter package as AWS Client

Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_aws_rest: ^0.2.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_aws_rest/flutter_aws_rest.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
29
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
35
Overall:
Weighted score of the above. [more]
16
Learn more about scoring.

We analyzed this package on Oct 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms:

Error(s) prevent platform classification:

Error(s) in lib/flutter_aws_rest.dart: Target of URI doesn't exist: 'package:logging/logging.dart'.

Health issues and suggestions

Fix lib/flutter_aws_rest.dart. (-43.75 points)

Analysis of lib/flutter_aws_rest.dart failed with 2 errors:

line 10 col 8: Target of URI doesn't exist: 'package:logging/logging.dart'.

line 29 col 21: Undefined class 'Logger'.

Document public APIs. (-1 points)

77 out of 77 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/cryptoutil.dart. (-1.49 points)

Analysis of lib/src/cryptoutil.dart reported 3 hints:

line 227 col 9: Name non-constant identifiers using lowerCamelCase.

line 308 col 7: The declaration '_MD5' isn't referenced.

line 386 col 7: The declaration '_SHA1' isn't referenced.

Format lib/src/request_payload.dart.

Run flutter format to format lib/src/request_payload.dart.

Format lib/src/request_signer.dart.

Run flutter format to format lib/src/request_signer.dart.

Format lib/src/s3_bucket_api.dart.

Run flutter format to format lib/src/s3_bucket_api.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Error(s) in lib/flutter_aws_rest.dart: Target of URI doesn't exist: 'package:logging/logging.dart'.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (intl).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flutter_aws_rest.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
crypto ^2.0.6 2.1.3
flutter 0.0.0
intl ^0.15.7 0.15.8 0.16.0
xml ^3.2.3 3.5.0
Transitive dependencies
charcode 1.1.2
collection 1.14.11 1.14.12
convert 2.1.1
meta 1.1.7
path 1.6.4
petitparser 2.4.0
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test