flutter_applaunch 0.0.4

flutter_applaunch #

A Flutter package that can retrive the URL Scheme parameters from app launch options.

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

Example: #

final FlutterApplaunchPlugin applaunchPlugin = new FlutterApplaunchPlugin();

Map<dynamic, dynamic> scheme = 
    await applaunchPlugin.getAppLaunchURLScheme();
setState(() {
    print("FlutterApplaunchPlugin -- App is launched by URL Scheme: $scheme");
});

The return value 'scheme' contains 2 keys:

  • url: the url scheme that launch the app
  • source (optional): the scheme of source application which calls the scheme the app (if exists)

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

example/README.md

flutter_applaunch_example #

Demonstrates how to use the flutter_applaunch plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flutter_applaunch: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flutter_applaunch/flutter_applaunch.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
6
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
51
Learn more about scoring.

We analyzed this package on Aug 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test