flipper_ui 0.0.1
flipper_ui: ^0.0.1 copied to clipboard

A new Flutter package project.

0
likes
70 / 120
pub points
47 %
popularity

We analyzed this package on Jun 13, 2021, and awarded it 70 pub points (of a possible 120):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 10

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
apptheme^0.0.10.0.11.0.0
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.4.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.0.1` on apptheme does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions apptheme to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.17.1, Flutter 2.2.1, Dart 2.13.1.

0
likes
70
pub points
47%
popularity

Publisher

Unknown

A new Flutter package project.

Homepage

License

LICENSE

Dependencies

apptheme, flutter

More

Packages that depend on flipper_ui