flib_lifecycle 1.0.0

  • Readme
  • Changelog
  • Installing
  • 51

About #

一个用来管理生命周期的库,库中的实现逻辑参考了android中的生命周期管理的库

Install #

  • git
  flib_lifecycle:
    git:
      url: git://github.com/zj565061763/flib_lifecycle
      ref: 1.0.0
  • pub
  dependencies:
    flib_lifecycle: ^1.0.0

Example #

class HomePage extends StatefulWidget {
  @override
  _HomePageState createState() => _HomePageState();
}

class _HomePageState extends State<HomePage> implements FLifecycleOwner {
  final FLifecycleRegistry _lifecycleRegistry = SimpleLifecycleRegistry();

  @override
  FLifecycle getLifecycle() {
    return _lifecycleRegistry;
  }

  @override
  void initState() {
    super.initState();
    // 分发事件
    _lifecycleRegistry.handleLifecycleEvent(FLifecycleEvent.onCreate);
  }

  @override
  Widget build(BuildContext context) {
    return Container();
  }

  @override
  void dispose() {
    super.dispose();
    // 分发事件
    _lifecycleRegistry.handleLifecycleEvent(FLifecycleEvent.onDestroy);
  }
}

1.0.0 #

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  flib_lifecycle: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:flib_lifecycle/flib_lifecycle.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
15
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
51
Learn more about scoring.

We analyzed this package on Dec 4, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/src/lifecycle_impl.dart. (-2.48 points)

Analysis of lib/src/lifecycle_impl.dart reported 5 hints:

line 158 col 47: Avoid using braces in interpolation when not needed.

line 170 col 24: Avoid using braces in interpolation when not needed.

line 172 col 47: Avoid using braces in interpolation when not needed.

line 180 col 24: Avoid using braces in interpolation when not needed.

line 186 col 47: Avoid using braces in interpolation when not needed.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and flib_lifecycle.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test