fl_theme 0.0.4
fl_theme: ^0.0.4 copied to clipboard

A new Flutter package project.

1
likes
60 / 130
pub points
0 %
popularity

We analyzed this package on May 18, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 70 API elements (2.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:fl_theme/fl_theme.dart that imports:
  • package:fl_theme/src/fl_theme_widget.dart that imports:
  • package:fl_theme/src/fl_theme.dart that imports:
  • package:hive_flutter/hive_flutter.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

INFO: The declaration '_$identity' isn't referenced.

lib/src/types/theme_brightness.freezed.dart:10:3

   ╷
10 │ T _$identity<T>(T value) => value;
   │   ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/types/theme_brightness.freezed.dart

INFO: Name non-constant identifiers using lowerCamelCase.

lib/src/types/theme_brightness.g.dart:9:9

  ╷
9 │ _$Light _$_$LightFromJson(Map<String, dynamic> json) {
  │         ^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/types/theme_brightness.g.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
freezed_annotation^0.12.00.12.00.14.2
hive^1.4.4+11.4.4+12.0.4
hive_flutter^0.3.10.3.11.0.0
json_annotation^3.1.03.1.14.0.1
rxdart^0.24.10.24.10.27.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
ffi-1.0.01.0.0
file-6.1.16.1.1
meta-1.3.01.3.0
path-1.8.01.8.0
path_provider-1.6.282.0.1
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.1
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.2.14.2.1
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.0.52.0.5
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^0.12.0` on freezed_annotation does not support the stable version `0.14.0`.

Try running dart pub upgrade --major-versions freezed_annotation to update the constraint.

The constraint `^1.4.4+1` on hive does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions hive to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.6, Dart 2.12.3.