firebase_remote_config_hybrid_web 0.0.1

  • Readme
  • Changelog
  • Installing
  • 66

firebase_remote_config_hybrid_web #

Web implementation of firebase_remote_config_hybrid

Usage #

Import the package #

This package is the endorsed implementation of firebase_remote_config_hybrid for the web platform since version 0.0.1, so it gets automatically added to your dependencies by depending on firebase_remote_config_hybrid: ^0.0.1.

No modifications to your pubspec.yaml should be required in a recent enough version of Flutter (>=1.12.13+hotfix.4):

...
dependencies:
  ...
  firebase_remote_config_hybrid: ^0.0.1
  ...

[0.0.1] #

  • Initialized plugin based on firebase_remote_config and firebase_dart implementations

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  firebase_remote_config_hybrid_web: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:firebase_remote_config_hybrid_web/firebase_remote_config_hybrid_web.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
41
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
79
Overall:
Weighted score of the above. [more]
66
Learn more about scoring.

We analyzed this package on Jul 12, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform android

Because:

  • package:firebase_remote_config_hybrid_web/firebase_remote_config_hybrid_web.dart that declares support for platforms: web

Package does not support Flutter platform ios

Because:

  • package:firebase_remote_config_hybrid_web/firebase_remote_config_hybrid_web.dart that declares support for platforms: web

Package does not support Flutter platform linux

Because:

  • package:firebase_remote_config_hybrid_web/firebase_remote_config_hybrid_web.dart that declares support for platforms: web

Package does not support Flutter platform macos

Because:

  • package:firebase_remote_config_hybrid_web/firebase_remote_config_hybrid_web.dart that declares support for platforms: web

Package does not support Flutter platform web

Because:

  • package:firebase_remote_config_hybrid_web/firebase_remote_config_hybrid_web.dart that imports:
  • package:firebase_remote_config_hybrid_platform_interface/firebase_remote_config_hybrid_platform_interface.dart that imports:
  • package:firebase_remote_config/firebase_remote_config.dart that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because:

  • package:firebase_remote_config_hybrid_web/firebase_remote_config_hybrid_web.dart that declares support for platforms: web

Package not compatible with SDK dart

Because:

  • firebase_remote_config_hybrid_web that is a package requiring null.

Health issues and suggestions

Document public APIs. (-1 points)

13 out of 13 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and firebase_remote_config_hybrid_web.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-1 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
firebase ^7.2.0 7.3.0
firebase_remote_config_hybrid_platform_interface ^0.0.1 0.0.1
flutter 0.0.0
flutter_web_plugins 0.0.0
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
firebase_remote_config 0.3.1
http 0.12.1
http_parser 3.1.4
path 1.7.0
pedantic 1.9.0 1.9.2
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
js ^0.6.1 0.6.2
meta ^1.1.7 1.1.8 1.2.2