firebase_remote_config_hybrid 0.0.1

FirebaseRemoteConfig #

pub package

A hybrid firebase remote config plugin (Android, iOS and web), This plugin is based on firebase_remote_config for mobile and firebase for web.

Usage #

To use this plugin, add firebase_remote_config_hybrid as a dependency in your pubspec.yaml file.

Web integration #

In addition to the firebase_remote_config_hybrid dependency, you'll need to modify the web/index.html of your app.

Getting Started #

See the example directory for a complete sample app using FirebaseRemoteConfig.

[0.0.1]

  • Initialized plugin based on firebase_remote_config and firebase_dart implementations

example/README.md

flutter_plugin_template_example #

pub package

Demonstrates how to use the flutter_plugin_template plugin.

Running on Web #

flutter run -d chrome

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  firebase_remote_config_hybrid: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:firebase_remote_config_hybrid/firebase_remote_config_hybrid.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
15
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
72
Overall:
Weighted score of the above. [more]
52
Learn more about scoring.

We analyzed this package on Feb 13, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Health issues and suggestions

Document public APIs. (-1 points)

18 out of 18 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

The package description is too short. (-18 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
firebase_remote_config_hybrid_platform_interface ^0.0.1 0.0.1
firebase_remote_config_hybrid_web ^0.0.1 0.0.1
flutter 0.0.0
Transitive dependencies
async 2.4.0
charcode 1.1.3
collection 1.14.11 1.14.12
firebase 7.2.1
firebase_remote_config 0.3.0+1
flutter_web_plugins 0.0.0
http_parser 3.1.3
js 0.6.1+1
meta 1.1.8
path 1.6.4
pedantic 1.9.0
sky_engine 0.0.99
source_span 1.6.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
e2e ^0.2.1
flutter_driver
flutter_test
http ^0.12.0 0.12.0+4
test any
uuid ^1.0.0