firebase_image 0.1.5
firebase_image: ^0.1.5 copied to clipboard

A cached Flutter ImageProvider for Firebase Cloud Storage image objects.

77
likes
90 / 130
pub points
90 %
popularity

We analyzed this package on Jun 5, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 12 API elements (75.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:firebase_image/firebase_image.dart that imports:
  • package:firebase_image/src/firebase_image.dart that imports:
  • package:firebase_storage/firebase_storage.dart that declares support for platforms: Android, iOS, macOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_core^0.4.3+10.4.51.2.1
firebase_storage^3.1.03.1.68.1.1
flutterflutter0.0.00.0.0
path^1.6.41.8.01.8.0
path_provider^1.3.01.6.282.0.2
sqflite^1.1.6+51.3.2+42.0.0+3
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
ffi-1.1.21.1.2
file-6.1.16.1.1
firebase-7.3.39.0.1
firebase_core_platform_interface-1.0.44.0.1
firebase_core_web-0.1.1+21.1.0
flutter_web_plugins-0.0.00.0.0
http-0.12.20.13.3
http_parser-3.1.44.0.0
js-0.6.30.6.3
matcher-0.12.100.12.10
meta-1.3.01.4.0
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.1
pedantic-1.11.01.11.0
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.2.14.2.1
quiver-2.1.53.0.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite_common-1.0.3+32.0.0+2
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
synchronized-2.2.0+23.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.1.32.1.3
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.4.3+1` on firebase_core does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions firebase_core to update the constraint.

The constraint `^3.1.0` on firebase_storage does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions firebase_storage to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.17.1, Flutter 2.2.1, Dart 2.13.1.

77
likes
90
pub points
90%
popularity

Publisher

mattreid.dev

A cached Flutter ImageProvider for Firebase Cloud Storage image objects.

Repository (GitHub)
View/report issues

Documentation

API reference

License

LICENSE

Dependencies

firebase_core, firebase_storage, flutter, path, path_provider, sqflite

More

Packages that depend on firebase_image