expr 0.0.0

Travis Codecov

Expr library #

This library is aimed at replacing the use of eqlib in QEDb. The design goals are as follows:

  • Design easier expression data structure (array instead of tree).
  • Adopt expression parsing and LaTeX printing code from eqlib.
  • Create codecs that are compatible with the array and binary codec from eqlib.
  • Avoid the use of a Subs class as much as possible using plain functions.
  • Add more flexible manipulation and comparison methods that are targeted at the use cases of QEDb.

The reason to reimplement this part of the QEDb project from scratch is to ensure high code quality and avoid the accumulation of obscure features. When eqlib was designed many of the current design choices of QEDb were still unknown.

Structure #

The library has three parts: the core functions, the interface functions, and the lemma functions. The core functions focus only on expression manipulation in general and do not implement any higher level system. The interface functions contain the expression parser, text generator (printer), and binary codec. The lemma functions implement a higher level system for building proofs (lemmas) using the algorithms implemented in this library.

Renaming #

Some entity names have changed with respect to eqlib in order to improve readability:

  • Generic functions are now called patterns
  • Substitutions are now called transforms
  • Rules are now called formulas
  • Steps are now called rewrites
  • Proofs are now called lemmas

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  expr: ^0.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:expr/expr.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0