expected_response_generator 1.0.0+1

  • Readme
  • Changelog
  • Installing
  • 48

Expected Response Generator #

Is a builder, to generate code to the package expected response.

Getting Started #

Installing #

Add the following to your pubspec

dependencies:
    expected_response: ^1.0.0

dev_dependencies:
    build_runner: ^1.0.0
    expected_response_generator: ^1.0.0

run pub get

Using #

Well, the ideia is you dont use it alone :P, this is part of the expected_response package, please refear to https://pub.dev/packages/expected_response

1.0.0 #

  • Basic generator done;

1.0.0+1 #

  • Add example

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  expected_response_generator: ^1.0.0+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:expected_response_generator/expected_response_generator.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Dec 12, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.13.1+4

Health suggestions

Format lib/builder.dart.

Run dartfmt to format lib/builder.dart.

Format lib/expected_response_generator.dart.

Run dartfmt to format lib/expected_response_generator.dart.

Format lib/src/entry_function_creator.dart.

Run dartfmt to format lib/src/entry_function_creator.dart.

Format lib/src/expected_response_generator.dart.

Run dartfmt to format lib/src/expected_response_generator.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (analyzer).

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and expected_response_generator.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
analyzer ^0.38.2 0.38.5 0.39.2+1
build >=0.12.0 <2.0.0 1.2.2
expected_response ^1.0.0 1.0.0+1
source_gen ^0.9.0 0.9.4+6
Transitive dependencies
args 1.5.2
async 2.4.0
charcode 1.1.2
collection 1.14.12
convert 2.1.1
crypto 2.1.4
csslib 0.16.1
dart_style 1.3.3
front_end 0.1.27 0.1.29
glob 1.2.0
html 0.14.0+3
js 0.6.1+1
kernel 0.3.27 0.3.29
logging 0.11.3+2
meta 1.1.8
node_interop 1.0.3
node_io 1.0.1+2
package_config 1.1.0
path 1.6.4
pedantic 1.9.0
pub_semver 1.4.2
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+13
yaml 2.2.0
Dev dependencies
build_runner ^1.0.0
build_test ^0.10.0
test ^1.0.0