expanding_picker_sheet 0.0.6

Expanding_Picker_Sheet #

pub package

Expanding Picker Sheet allow you to select an item from sheet with a thumbnail preview of the selected item in a Flutter project using this library

Based on Expanding Bottom Sheet from Shrine in Flutter example apps

Getting Started #

Follow this article coming soon

Example #

checkout the sample code in example

Example Example Example

Contribute #

  1. You'll need a GitHub account. (Sorry, if you had to create one!!)
  2. Fork the repository.
  3. Implement improvements
  4. Send merge request.
  5. Star this project.
  6. Become a hero!!

[0.0.6] - Updated Files

Updated Files

[0.0.5] - Updated example

Updated example

[0.0.4] - Updated Readme

Updated Readme

[0.0.3] - Updated Example & Screenshots.

Updated Example & Screenshots.

[0.0.2] - Updated Readme.

Updated Readme.

[0.0.1] - Initial Release with example app.

Initial Release with example app

example/README.md

example #

A new Flutter project.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  expanding_picker_sheet: ^0.0.6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:expanding_picker_sheet/expanding_picker_sheet.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
21
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
59
Learn more about scoring.

We analyzed this package on Sep 13, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test