exchange_rooms 0.0.5
exchange_rooms: ^0.0.5 copied to clipboard

Getting appointments from a room on Exchange Server 2010+ using the EWS API. Simply use the email address of the room an get an array of appointments

1
likes
90 / 110
pub points
12 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 24 out of 51 API elements (47.1 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/models/room_list.dart:6:22

  ╷
6 │   List<Room> rooms = List<Room>();
  │                      ^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/models/room_list.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
http^0.12.20.12.20.13.1
xml^4.5.14.5.15.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
convert-2.1.13.0.0
http_parser-3.1.44.0.0
meta-1.3.01.3.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
petitparser-3.1.04.1.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.2` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^4.5.1` on xml does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions xml to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

1
likes
90
pub points
12%
popularity

Publisher

eloware.com

Getting appointments from a room on Exchange Server 2010+ using the EWS API. Simply use the email address of the room an get an array of appointments

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, http, xml

More

Packages that depend on exchange_rooms