essential_components 1.5.12
essential_components: ^1.5.12 copied to clipboard

A library for AngularDart developers. This library will implement several key components for the fast development of web applications with AngularDart.

9
likes
80 / 110
pub points
40 %
popularity

We analyzed this package on Mar 27, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 302 out of 1392 API elements (21.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:essential_components/essential_components.dart that imports:
  • package:essential_components/src/select_tree_dialog/select_tree_dialog.dart that imports:
  • package:essential_components/src/modal/modal.dart that imports:
  • package:angular_forms/angular_forms.dart that imports:
  • package:angular_forms/src/validators.dart that imports:
  • package:angular_forms/src/model.dart that imports:
  • package:angular_forms/src/directives/validators.dart that imports:
  • package:angular/angular.dart that imports:
  • package:angular/src/platform/browser/tools/tools.dart that imports:
  • package:angular/src/platform/browser/tools/common_tools.dart that imports:
  • package:angular/src/core/linker/component_factory.dart that imports:
  • package:angular/src/core/linker/views/host_view.dart that imports:
  • package:angular/src/core/linker/views/view.dart that imports:
  • dart:html
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 27 issues. Showing the first 2:

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/datepicker/day_picker.dart:58:17

   ╷
58 │     var dates = List<DateTime>(n);
   │                 ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/datepicker/day_picker.dart

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/datepicker/month_picker.dart:48:18

   ╷
48 │     var months = List<DisplayedDate>(12);
   │                  ^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/datepicker/month_picker.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angular>=5.3.0 <6.2.06.0.16.0.1
angular_forms>=2.1.2 <4.0.03.0.03.0.0
angular_router>=2.0.0-alpha <4.0.02.0.02.0.0
dart_browser_loader^0.0.6+10.0.6+10.1.0
decimal>=0.3.5 <2.5.01.0.01.0.0
essential_rest>=1.0.18 <2.5.01.1.221.1.22
essential_xlsx>=1.0.0 <2.5.01.1.01.1.0
http>=0.12.0 <2.0.00.12.20.13.1
intl>=0.15.8 <2.5.00.16.10.17.0
js^0.6.1+10.6.30.6.3
sass_builder>=2.1.2 <2.5.02.1.32.1.3
xml>=3.7.0 <4.0.03.7.05.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-12.0.019.0.0
analyzer-0.40.61.3.0
angular_ast-1.0.11.0.1
angular_compiler-1.0.11.0.1
archive-2.0.133.1.2
args-1.6.02.0.0
async-2.5.02.5.0
build-1.6.22.0.0
build_config-0.4.70.4.7
built_collection-5.0.05.0.0
built_value-8.0.48.0.4
charcode-1.2.01.2.0
checked_yaml-1.0.42.0.1
cli_repl-0.2.10.2.1
cli_util-0.2.00.3.0
code_builder-3.7.03.7.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
csslib-0.16.20.17.0
dart_style-1.3.102.0.0
file-5.2.16.1.0
fixnum-1.0.01.0.0
glob-1.2.02.0.1
html-0.14.0+40.15.0
http_parser-3.1.44.0.0
json_annotation-4.0.14.0.1
logging-0.11.41.0.1
matcher-0.12.100.12.10
meta-1.3.01.3.0
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
package_resolver-1.0.101.0.10
path-1.8.01.8.0
petitparser-3.1.04.0.2
pub_semver-1.4.42.0.0
pubspec_parse-0.1.81.0.0
quiver-2.1.53.0.0
rational-1.0.01.0.0
sass-1.32.81.32.8
source_gen-0.9.10+21.0.0
source_maps-0.10.100.10.10
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
tuple-1.0.32.0.0
typed_data-1.3.01.3.0
universal_html-1.2.42.0.7
universal_io-1.0.22.0.3
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0
zone_local-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.0.6+1` on dart_browser_loader does not support the stable version `0.1.0`, that was published 9 days ago.

When dart_browser_loader is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions dart_browser_loader to update the constraint.

The constraint `>=3.7.0 <4.0.0` on xml does not support the stable version `4.1.0`.

Try running dart pub upgrade --major-versions xml to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.1.

9
likes
80
pub points
40%
popularity

A library for AngularDart developers. This library will implement several key components for the fast development of web applications with AngularDart.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

insinfo2008@gmail.com

License

GPL 3.0 (LICENSE)

Dependencies

angular, angular_forms, angular_router, dart_browser_loader, decimal, essential_rest, essential_xlsx, http, intl, js, sass_builder, xml

More

Packages that depend on essential_components