essential_components 0.1.82
essential_components: ^0.1.82 copied to clipboard

A library for AngularDart developers. This library will implement several key components for the fast development of web applications with AngularDart.

9
likes
40 / 110
pub points
41 %
popularity

We analyzed this package on Mar 27, 2021, and awarded it 40 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run pub get for more information.

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 1744 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:angular/angular.dart'.

lib/src/accordion/accordion.dart:1:8

  ╷
1 │ import 'package:angular/angular.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/accordion/accordion.dart

ERROR: Undefined name 'Component' used as an annotation.

lib/src/accordion/accordion.dart:11:1

   ╷
11 │ ┌ @Component(
12 │ │     selector: 'es-accordion',
13 │ │     template: '<ng-content></ng-content>',
14 │ └     directives: [coreDirectives, EsAccordionPanelComponent])
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/accordion/accordion.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run pub outdated: pub get failed:
The current Dart SDK version is 2.12.1.

Because angular_components >=0.13.0 <1.0.3 depends on observable ^0.22.2 which depends on dart_internal ^0.1.1, angular_components >=0.13.0 <1.0.3 requires dart_internal ^0.1.1.
So, because dart_internal ^0.1.1 requires SDK version >=2.0.0-dev.12.0 <2.12.0 and essential_components depends on angular_components ^0.13.0+1, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.1.

9
likes
40
pub points
41%
popularity

A library for AngularDart developers. This library will implement several key components for the fast development of web applications with AngularDart.

Repository (GitHub)
View/report issues

Uploader

insinfo2008@gmail.com

License

GPL 3.0 (LICENSE)

Dependencies

angular, angular_components, angular_forms, angular_router, archive, decimal, http, http_parser, intl, sass_builder, uuid, xml

More

Packages that depend on essential_components