env_configurator 0.1.1
env_configurator: ^0.1.1 copied to clipboard

Dart native
Flutter Android iOS

A starting point for Dart libraries or applications.

0
likes
60 / 110
pub points
0 %
popularity

We analyzed this package on Jan 26, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/env_configurator_example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 4 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:env_configurator/env_configurator.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: The value of the local variable 'resp' isn't used.

lib/env_configurator.dart:97:17

   ╷
97 │           final resp = await srcFile.copy(targetFilePath);
   │                 ^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/env_configurator.dart

lib/env_configurator.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.5.21.6.01.6.0
colorize^2.0.02.0.02.0.0
recase^2.0.12.0.13.0.1
xml^3.5.03.7.04.5.1
yaml^2.2.02.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
meta-1.2.41.2.4
path-1.7.01.7.0
petitparser-3.1.03.1.0
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.1` on recase does not support the latest published version `3.0.1`

pubspec.yaml:15:11

   ╷
15 │   recase: ^2.0.1
   │           ^^^^^^
   ╵
The constraint `^3.5.0` on xml does not support the latest published version `4.5.1`

pubspec.yaml:14:8

   ╷
14 │   xml: ^3.5.0
   │        ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
60
pub points
0%
popularity

A starting point for Dart libraries or applications.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

mahmed8003@gmail.com

License

BSD (LICENSE)

Dependencies

args, colorize, recase, xml, yaml

More

Packages that depend on env_configurator