endorse 0.0.28
endorse: ^0.0.28 copied to clipboard

Library for validating arbitrary objects such as API responses.

0
likes
80 / 130
pub points
8 %
popularity

We analyzed this package on May 4, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 264 API elements (0.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 20 issues. Showing the first 2:

INFO: Unused import: 'package:endorse/src/endorse/validation_error.dart'.

lib/src/endorse/endorse_result.dart:3:8

  ╷
3 │ import 'package:endorse/src/endorse/validation_error.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/endorse/endorse_result.dart

INFO: Don't explicitly initialize variables to null.

lib/src/endorse/evaluator.dart:26:34

   ╷
26 │   void _runRule(ValueRule rule, [Object test = null]) {
   │                                  ^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/endorse/evaluator.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.9.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

0
likes
80
pub points
8%
popularity

Library for validating arbitrary objects such as API responses.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

kirklinkletter@gmail.com

License

BSD (LICENSE)

More

Packages that depend on endorse