ejdb2_flutter 1.0.7+1
ejdb2_flutter: ^1.0.7+1 copied to clipboard

Embeddable JSON Database engine EJDB http://ejdb.org Flutter binding.

4
likes
80 / 130
pub points
44 %
popularity

We analyzed this package on Jun 26, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 35 out of 79 API elements (44.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:ejdb2_flutter/ejdb2_flutter.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/ejdb2_flutter.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
json_at^1.0.41.0.42.1.0
pedantic^1.8.0+11.11.11.11.1
quiver^2.0.52.1.53.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.022.0.0
analyzer-1.7.11.7.1
args-2.1.12.1.1
async-2.7.02.7.0
boolean_selector-2.1.02.1.0
characters-1.1.01.1.0
charcode-1.3.11.3.1
cli_util-0.3.10.3.1
collection-1.15.01.15.0
convert-3.0.13.0.1
coverage-1.0.31.0.3
crypto-3.0.13.0.1
file-6.1.26.1.2
frontend_server_client-2.1.02.1.0
glob-2.0.12.0.1
http_multi_server-3.0.13.0.1
http_parser-4.0.04.0.0
io-1.0.01.0.0
js-0.6.30.6.3
logging-1.0.11.0.1
matcher-0.12.100.12.10
meta-1.3.01.4.0
mime-1.0.01.0.0
node_preamble-2.0.12.0.1
package_config-2.0.02.0.0
path-1.8.01.8.0
pool-1.5.01.5.0
pub_semver-2.0.02.0.0
shelf-1.1.41.1.4
shelf_packages_handler-3.0.03.0.0
shelf_static-1.0.01.0.0
shelf_web_socket-1.0.11.0.1
sky_engine-0.0.990.0.99
source_map_stack_trace-2.1.02.1.0
source_maps-0.10.100.10.10
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
test-1.17.91.17.9
test_api-0.4.10.4.1
test_core-0.3.290.3.29
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
vm_service-7.1.07.1.0
watcher-1.0.01.0.0
web_socket_channel-2.1.02.1.0
webkit_inspection_protocol-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.4` on json_at does not support the stable version `2.1.0`, that was published 4 days ago.

When json_at is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions json_at to update the constraint.

The constraint `^2.0.5` on quiver does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions quiver to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.5.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Flutter 2.2.2, Dart 2.13.3.

4
likes
80
pub points
44%
popularity

Publisher

ejdb.org

Embeddable JSON Database engine EJDB http://ejdb.org Flutter binding.

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, json_at, pedantic, quiver

More

Packages that depend on ejdb2_flutter