edropinapi_accounts 1.0.0
edropinapi_accounts: ^1.0.0 copied to clipboard

OpenAPI API client

0
likes
45 / 130
pub points
0 %
popularity

We analyzed this package on Jul 23, 2021, and awarded it 45 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 45 out of 796 API elements (5.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:edropinapi_accounts/api.dart that imports:
  • package:http/http.dart that imports:
  • package:http/src/streamed_response.dart that imports:
  • package:http/src/base_request.dart that imports:
  • package:http/src/client.dart that imports:
  • package:http/src/io_client.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 54 issues. Showing the first 2:

lib/api.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/api/ea_accounts_api.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http>=0.11.1 <0.12.00.11.3+170.13.3
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.12.8.1
charcode-1.3.11.3.1
collection-1.15.01.15.0
http_parser-3.1.44.0.0
meta-1.7.01.7.0
path-1.8.01.8.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.11.1 <0.12.0` on http does not support the stable version `0.12.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Dart 2.13.4.