duration_parser 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 0

duration_parser #

Module for parsing ISO 8601 durations.

Parse Duration #

Use parse to get a Duration from an ISO 8601 string. Check out the details on Wikipedia

import 'package:duration_parser/duration_parser.dart';

main() {
    print(parse('PT32M11S'));
    /// => 0:32:11.000000

    var duration = parse('P1W');
    print(duration.inDays);
    /// => 7
}

1.0.0 #

  • Parse ISO 8601 durations.

example/duration_parser_example.dart

import 'package:duration_parser/duration_parser.dart';

main() {
    print(parse('PT32M11S'));
    /// => 0:32:11.000000

    var duration = parse('P1W');
    print(duration.inDays);
    /// => 7
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  duration_parser: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:duration_parser/duration_parser.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.