dropsource_app_utilities 0.0.3+4

  • Readme
  • Changelog
  • Installing
  • 41

app_utilities #

A new Flutter package project.

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[0.0.1] - TODO: Add release date. #

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dropsource_app_utilities: ^0.0.3+4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dropsource_app_utilities/dropsource_app_utilities.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
41
Learn more about scoring.

We analyzed this package on Jul 12, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:dropsource_app_utilities/dropsource_app_utilities.dart that imports:
  • package:dropsource_app_utilities/src/app_config.dart that imports:
  • package:firebase_crashlytics/firebase_crashlytics.dart that declares support for platforms: android, ios, macos

Package does not support Flutter platform web

Because:

  • package:dropsource_app_utilities/dropsource_app_utilities.dart that imports:
  • package:dropsource_app_utilities/src/app_config.dart that imports:
  • package:firebase_crashlytics/firebase_crashlytics.dart that declares support for platforms: android, ios, macos

Package does not support Flutter platform windows

Because:

  • package:dropsource_app_utilities/dropsource_app_utilities.dart that imports:
  • package:dropsource_app_utilities/src/app_config.dart that imports:
  • package:firebase_crashlytics/firebase_crashlytics.dart that declares support for platforms: android, ios, macos

Package not compatible with SDK dart

Because:

  • dropsource_app_utilities that is a package requiring null.

Health suggestions

Fix lib/src/ui/text_themes.dart. (-1.99 points)

Analysis of lib/src/ui/text_themes.dart reported 4 hints:

line 17 col 42: 'title' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is headline6. This feature was deprecated after v1.13.8..

line 70 col 42: 'body1' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is bodyText2. This feature was deprecated after v1.13.8..

line 89 col 42: 'body2' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is bodyText1. This feature was deprecated after v1.13.8..

line 129 col 42: 'headline' is deprecated and shouldn't be used. This is the term used in the 2014 version of material design. The modern term is headline5. This feature was deprecated after v1.13.8..

Fix lib/src/stream_manager.dart. (-0.50 points)

Analysis of lib/src/stream_manager.dart reported 1 hint:

line 11 col 8: The value of the field '_isDirty' isn't used.

Format lib/src/hex_color.dart.

Run flutter format to format lib/src/hex_color.dart.

Format lib/src/networking.dart.

Run flutter format to format lib/src/networking.dart.

Format lib/src/ui/platform_widgets.dart.

Run flutter format to format lib/src/ui/platform_widgets.dart.

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (provider, rxdart).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and dropsource_app_utilities.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
dio ^3.0.7 3.0.9
firebase_analytics ^5.0.6 5.0.16
firebase_core ^0.4.2 0.4.5
firebase_crashlytics ^0.1.1+2 0.1.3+3
flutter 0.0.0
provider ^3.1.0+1 3.2.0 4.3.1
rxdart ^0.22.6 0.22.6 0.24.1
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
firebase 7.3.0
firebase_analytics_platform_interface 1.0.1
firebase_analytics_web 0.1.1
firebase_core_platform_interface 1.0.4
firebase_core_web 0.1.1+2
flutter_web_plugins 0.0.0
http 0.12.1
http_parser 3.1.4
js 0.6.2
matcher 0.12.8
meta 1.1.8 1.2.2
path 1.7.0
pedantic 1.9.0 1.9.2
plugin_platform_interface 1.0.2
quiver 2.1.3
sky_engine 0.0.99
source_span 1.7.0
stack_trace 1.9.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test