draggable_container 0.1.8+1
draggable_container: ^0.1.8+1 copied to clipboard

A Draggable Widget Container. Each children is Draggable, Deletable and Fixable.

5
likes
90 / 110
pub points
40 %
popularity

We analyzed this package on Apr 11, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 12 out of 155 API elements (7.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'overflow' is deprecated and shouldn't be used. Use clipBehavior instead. See the migration guide in flutter.dev/go/clip-behavior. This feature was deprecated after v1.22.0-12.0.pre..

lib/draggable_container.dart:669:13

    ╷
669 │             overflow: Overflow.visible,
    │             ^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/draggable_container.dart

INFO: 'Overflow' is deprecated and shouldn't be used. Use clipBehavior instead. See the migration guide in flutter.dev/go/clip-behavior. This feature was deprecated after v1.22.0-12.0.pre..

lib/draggable_container.dart:669:23

    ╷
669 │             overflow: Overflow.visible,
    │                       ^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/draggable_container.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

5
likes
90
pub points
40%
popularity

A Draggable Widget Container. Each children is Draggable, Deletable and Fixable.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

gzlock88@gmail.com

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on draggable_container