dquery 0.8.5

  • Readme
  • Changelog
  • Installing
  • 33


DQuery is a porting of jQuery in Dart.

##Install from Dart Pub Repository

Include the following in your pubspec.yaml:

  dquery: any

Then run the Pub Package Manager in Dart Editor (Tool > Pub Install). If you are using a different editor, run the command (comes with the Dart SDK):

pub install


You can create a query object by selector. With context provided, the query will be based on different element.

// selects all elements containing 'active' in CSS class
ElementQuery $elems = $('.active');

// selects all descendant elements of div containing 'active' in CSS class
ElementQuery $elems = $('.active', div);

It implements List

for (Element e in $('.active')) { ... }

Create another query object with traversing API, including find, closest, parent, children.


Manipulate selected elements.


Register event handlers on queried elements, or trigger an event by API.

$('#myBtn').on('click', (QueryEvent e) {
$('#myBtn').trigger('click', data: 'my data');

There are query objects of Document and Window too.

Query $doc = $document();
Query $win = $window();

Check the API reference for more features.

##Comparison to jQuery

See here.

##Notes to Contributors

###Test and Debug

You are welcome to submit bugs and feature requests. Or even better if you can fix or implement them!

###Fork DQuery

If you'd like to contribute back to the core, you can fork this repository and send us a pull request, when it is ready.

Please be aware that one of Rikulo's design goals is to keep the sphere of API as neat and consistency as possible. Strong enhancement always demands greater consensus.

If you are new to Git or GitHub, please read this guide first.

##Who Uses

  • Quire - a simple, collaborative, multi-level task management tool.



  • QueryEvent.shiftKey introduced.


  • Deprecate QueryEvent.type since Dart 1.16 doesn't support MouseEvent.which, and it is not non-standard.
  • Deprecate keyLocation. Use location instead.


  • Remove QueryEvent's isDefaultPrevented and isPropagationStopped. Please use defaultPrevented and propagationStopped instead.


  • Remove QueryEvent's which and clipboardData to be compatible with Dart 1.16


  • Close #11: QueryEvent implements Event

Fixed client error when access pageX (Firefox) #


  • Refector: DQuery doesn't depend on Event.target/type for basic event handling


  • Focus/blur event bubbling ready.
  • Fix mouseenter/mouseleave delegate event.
  • Fix delegate target not found error.
  • Removed deprecated event API.
  • Fine tune QueryEvent constructor.


  • #6: DocumentQuery supported cookie API.
  • #2: QueryEvent supported keystroke API.


  • Fix event memory issue.


  • Query was added for query any object including shadow roots.
  • DocumentQuery and WindowQuery were removed, and replaced with DQuery.
  • DQueryEvent was renamed to QueryEvent.
  • Data.space() became a getter: Date.space


  • Fix event name space.
  • Fix data remove.
  • Fine tune JavaScript compatibility.


  • Add getter/setter of offset, getter of offsetLeft, offsetTop
  • Add getter of offsetParent
  • Add getter/setter of html, text
  • Add .clone()
  • Add .append(), .prepend(), .after(), .before()
  • Add .appendTo(), .prependTo()
  • Minor bug fixes


  • Add $(html) support.
  • Add getter, setter of scrollLeft, scrollTop
  • Add .css()
  • Add getter of width, height

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  dquery: ^0.8.5

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:dquery/dquery.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.2.0