dom 0.2.0

  • Installing
  • Versions
  • 9

dom #

A virtual DOM library for Dart.

Yet another library? #

The goal of package:dom is to be absolutely framework or implementation agnostic and instead provide a rich but simple set of classes to represent a virtual DOM tree and utilities for working with them.

By default, nodes are:

  • Deeply immutable (equality and hash-able)
  • Serializable (with a proof-of-concept JSON codec)
  • Have nothing specific to any rendering implementation

This should be enough to build on or extend for most implementations.

0.2.0 #

  • Remove Attribute and add a Map of attributes for Element

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  dom: ^0.2.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:dom/dom.dart';
Version Uploaded Documentation Archive
0.2.0 Jan 29, 2017 Go to the documentation of dom 0.2.0 Download dom 0.2.0 archive
0.1.0 Jan 27, 2017 Go to the documentation of dom 0.1.0 Download dom 0.1.0 archive
0.0.0-dev-1 Mar 10, 2015 Go to the documentation of dom 0.0.0-dev-1 Download dom 0.0.0-dev-1 archive
0.0.0-dev+1 Mar 11, 2015 Go to the documentation of dom 0.0.0-dev+1 Download dom 0.0.0-dev+1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.0 <2.0.0