dl_bubble 0.0.1

  • Readme
  • Changelog
  • Installing
  • 48

dl_bubble #


demo 运行示例图 #

Getting Started #

import 'package:dl_bubble/dl_bubble.dart';

          child: Container(
        padding: const EdgeInsets.only(top: 50, left: 10, right: 10),
        child: Wrap(
          spacing: 30,
          runSpacing: 20,
          children: <Widget>[
              text: '1',
              textStyle: const TextStyle(fontSize: 18, color: Colors.white),
              badgeTextPadding: const EdgeInsets.all(10),
              positionedRight: -15,
              positionedTop: -20,
              child: Container(
                width: 100,
                height: 100,
                color: Colors.black,
              number: 18,
              child: Container(
                width: 50,
                height: 50,
                color: Colors.black,
              number: 100,
              child: Container(
                width: 100,
                height: 100,
                color: Colors.black,
              text: '利口酒',
              child: Container(
                width: 100,
                height: 100,
                color: Colors.black,
              text: '',
              child: Container(
                width: 60,
                height: 60,
                color: Colors.black,

[0.0.1] - TODO: Add release date. #

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  dl_bubble: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:dl_bubble/dl_bubble.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart


  • dl_bubble that is a package requiring null.

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and dl_bubble.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies