discord 0.15.0

  • README.md
  • Installing
  • Versions
  • 0

Discord Dart #

Build Status Our Discord Server Pub


A Dart library for Discord

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  discord: ^0.15.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:discord/discord.dart';
  
Version Uploaded Documentation Archive
0.15.0 Oct 23, 2016 Go to the documentation of discord 0.15.0 Download discord 0.15.0 archive
0.14.2 Oct 20, 2016 Go to the documentation of discord 0.14.2 Download discord 0.14.2 archive
0.14.1 Oct 19, 2016 Go to the documentation of discord 0.14.1 Download discord 0.14.1 archive
0.14.0 Oct 17, 2016 Go to the documentation of discord 0.14.0 Download discord 0.14.0 archive
0.13.3 Oct 15, 2016 Go to the documentation of discord 0.13.3 Download discord 0.13.3 archive
0.13.2 Oct 15, 2016 Go to the documentation of discord 0.13.2 Download discord 0.13.2 archive
0.13.1 Oct 15, 2016 Go to the documentation of discord 0.13.1 Download discord 0.13.1 archive
0.13.0 Oct 15, 2016 Go to the documentation of discord 0.13.0 Download discord 0.13.0 archive
0.12.0 Oct 10, 2016 Go to the documentation of discord 0.12.0 Download discord 0.12.0 archive
0.11.1 Oct 2, 2016 Go to the documentation of discord 0.11.1 Download discord 0.11.1 archive

All 13 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.