digiselfie_sdk 0.0.8

  • Readme
  • Changelog
  • Installing
  • 56

digiselfie_sdk #

SDK for social network as a service (SNaaS) platform - DigiSelfie ( https://www.digiselfie.com )

Getting Started #

[0.0.8] - October 13, 2019

  • Added logout() method to ApiClient

[0.0.7] - October 6, 2019

  • Safe-wrapped DigitalSelfie object for UI-friendliness
  • Performed all-way code refactoring

[0.0.6] - September 9, 2019

  • Made ApiClient.accessTokenJar public for better token accessibility

[0.0.5] - September 9, 2019

  • Implemented proper handling of 'expires_in' parameter on the access token

[0.0.4] - September 9, 2019

  • Added ability to check the validity of the API connection ( ApiClient.checkConnection() )
  • Added refresh_token flow

[0.0.3] - September 5, 2019

  • Resolved code styling issues

[0.0.2] - September 5, 2019

  • Updated dependencies to the most recent versions
  • Performed code formatting
  • Resolved code styling issues

[0.0.1] - September 5, 2019

  • Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  digiselfie_sdk: ^0.0.8

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:digiselfie_sdk/digiselfie_sdk.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
29
Health:
Code health derived from static analysis. [more]
86
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
56
Learn more about scoring.

We analyzed this package on Nov 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, other

Primary library: package:digiselfie_sdk/digiselfie_sdk.dart with components: io.

Health issues and suggestions

Document public APIs. (-1 points)

580 out of 580 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/models/mixins.dart. (-6.78 points)

Analysis of lib/models/mixins.dart reported 14 hints, including:

line 99 col 21: Unnecessary new keyword.

line 108 col 21: Unnecessary new keyword.

line 117 col 24: Unnecessary new keyword.

line 126 col 29: Unnecessary new keyword.

line 135 col 9: Use isNotEmpty instead of length

Fix lib/api/client/api.client.dart. (-3.93 points)

Analysis of lib/api/client/api.client.dart reported 8 hints, including:

line 18 col 7: Unnecessary new keyword.

line 98 col 13: Unnecessary new keyword.

line 149 col 13: Unnecessary new keyword.

line 152 col 25: Unnecessary new keyword.

line 227 col 13: Unnecessary new keyword.

Fix lib/api/client/api.dart. (-0.50 points)

Analysis of lib/api/client/api.dart reported 1 hint:

line 18 col 20: Use ; instead of {} for empty constructor bodies.

Fix additional 9 files with analysis or formatting issues. (-2 points)

Additional issues in the following files:

  • lib/api/client/image.api.dart (1 hint)
  • lib/models/api_key.dart (1 hint)
  • lib/models/digiselfie.dart (1 hint)
  • lib/models/image.dart (1 hint)
  • lib/api/client/selfies.api.dart (Run dartfmt to format lib/api/client/selfies.api.dart.)
  • lib/api/client/special.type.payload.dart (Run dartfmt to format lib/api/client/special.type.payload.dart.)
  • lib/models/access_token.dart (Run dartfmt to format lib/models/access_token.dart.)
  • lib/models/api_object.dart (Run dartfmt to format lib/models/api_object.dart.)
  • lib/models/basic_types.dart (Run dartfmt to format lib/models/basic_types.dart.)

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and digiselfie_sdk.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
build_runner ^1.0.0 1.7.2
build_test ^0.10.3 0.10.9+1
http ^0.12.0+2 0.12.0+2
json_annotation ^3.0.0 3.0.0
json_serializable ^3.0.0 3.2.3
meta ^1.1.7 1.1.8
pedantic ^1.8.0+1 1.8.0+1
test >=0.12.42 <2.0.0 1.9.4
Transitive dependencies
analyzer 0.38.5 0.39.1
args 1.5.2
async 2.4.0
boolean_selector 1.0.5
build 1.2.2
build_config 0.4.1+1
build_daemon 2.1.2
build_resolvers 1.2.1 1.3.0
build_runner_core 4.2.0
built_collection 4.3.0
built_value 7.0.0
charcode 1.1.2
checked_yaml 1.0.2
code_builder 3.2.1
collection 1.14.12
convert 2.1.1
coverage 0.13.3+1
crypto 2.1.3
csslib 0.16.1
dart_style 1.3.3
fixnum 0.10.11
front_end 0.1.27 0.1.29
glob 1.2.0
graphs 0.2.0
html 0.14.0+3
http_multi_server 2.1.0
http_parser 3.1.3
io 0.3.3
js 0.6.1+1
kernel 0.3.27 0.3.29
logging 0.11.3+2
matcher 0.12.6
mime 0.9.6+3
multi_server_socket 1.0.2
node_interop 1.0.3
node_io 1.0.1+2
node_preamble 1.4.8
package_config 1.1.0
package_resolver 1.0.10
path 1.6.4
pool 1.4.0
pub_semver 1.4.2
pubspec_parse 0.1.5
quiver 2.1.2+1
shelf 0.7.5
shelf_packages_handler 1.0.4
shelf_static 0.2.8
shelf_web_socket 0.2.3
source_gen 0.9.4+6
source_map_stack_trace 1.1.5
source_maps 0.10.8
source_span 1.5.5
stack_trace 1.9.3
stream_channel 2.0.0
stream_transform 0.0.20
string_scanner 1.0.5
term_glyph 1.1.0
test_api 0.2.11
test_core 0.2.15
timing 0.1.1+2
typed_data 1.1.6
vm_service 2.1.1
watcher 0.9.7+12
web_socket_channel 1.1.0
yaml 2.2.0