dialog_ahihi 0.0.2
dialog_ahihi: ^0.0.2 copied to clipboard

Flutter Android iOS

A new Flutter plugin.

0
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Jan 21, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 8 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:dialog_ahihi/dialog_ahihi.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: Unused import: 'package:flutter/services.dart'.

lib/dialog_ahihi.dart:4:8

  ╷
4 │ import 'package:flutter/services.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/dialog_ahihi.dart

INFO: 'child' is deprecated and shouldn't be used. Instead of using the "child" argument, return the child from a closure provided to the "builder" argument. This will ensure that the BuildContext is appropriate for widgets built in the dialog. This feature was deprecated after v0.2.3..

lib/dialog_ahihi.dart:27:7

   ╷
27 │       child: WillPopScope(
   │       ^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/dialog_ahihi.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
70
pub points
0%
popularity

A new Flutter plugin.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ducduy.dev@gmail.com

License

unknown (LICENSE)

Dependencies

flutter

More

Packages that depend on dialog_ahihi