demo_caja_dart 0.0.1
demo_caja_dart: ^0.0.1 copied to clipboard

A new Flutter package.

0
likes
50 / 130
pub points
0 %
popularity

We analyzed this package on May 7, 2021, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://enalgunlugar.com/ was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 45 API elements (2.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:demo_caja_dart/demo_caja_dart.dart that imports:
  • package:demo_caja_dart/pos_sqlite.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

INFO: Name non-constant identifiers using lowerCamelCase.

lib/demo_caja_dart.dart:8:10

  ╷
8 │   String tienda_id;
  │          ^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/demo_caja_dart.dart

INFO: The declaration '_login' isn't referenced.

lib/demo_caja_dart.dart:25:8

   ╷
25 │   void _login(String user, String pwd, [String endpoint]) async{
   │        ^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/demo_caja_dart.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
convert^2.1.12.1.13.0.0
couchbase_lite^2.5.02.8.12.8.1
crypto^2.0.62.1.53.0.1
flutterflutter0.0.00.0.0
path^1.6.21.8.01.8.0
sqflite^1.1.6+31.3.2+42.0.0+3
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.02.1.0
asn1lib-0.8.11.0.0
built_collection-4.3.25.0.0
built_value-7.1.08.0.6
characters-1.1.01.1.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
encrypt-4.1.05.0.0
fixnum-0.10.111.0.0
hex-0.1.20.2.0
matcher-0.12.100.12.10
meta-1.3.01.3.0
password_hash-2.0.02.0.0
pointycastle-2.0.13.0.1
quiver-2.1.53.0.1
sky_engine-0.0.990.0.99
sqflite_common-1.0.3+32.0.0+2
stack_trace-1.10.01.10.0
synchronized-2.2.0+23.0.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.4
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^2.1.1` on convert does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions convert to update the constraint.

The constraint `^2.0.6` on crypto does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions crypto to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.