datetime_helper 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 34

datetime_helper #

some common method for datetime method

pub package

pub #

install #

use #

[0.0.2] - update readme #

[0.0.1] - first version #


import 'package:datetime_helper/datetime_helper.dart';

void main() {
  var dateTime = DateHelper.getStartTimeOfDay(;

  print(dateTime); //2018-09-14 00:00:00.000

      DateTime.parse("2018-01-01"), DateTime.parse("2018-01-02"))); // false

  print(DateHelper.isAm(DateTime(2018, 1, 1, 0, 20))); // true
  print(DateHelper.isAm(DateTime(2018, 1, 1, 13, 20))); // false

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  datetime_helper: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:datetime_helper/datetime_helper.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Mar 31, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Health issues and suggestions

Document public APIs. (-1 points)

9 out of 9 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

Package is getting outdated. (-54.25 points)

The package was last published 80 weeks ago.

The package description is too short. (-15 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
Dev dependencies
test ^1.3.2