date_text_input_formatter 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 71

DateInputTextFormatter #

Usage #

Add to pub

dependencies:
 date_input_text_formatter: ^0.0.1

Import

import  'package:date_text_input_formatter/date_text_input_formatter.dart';

Use

inputFormatters:  <TextInputFormatter>[
DateTextInputFormatter(delimiter:  "-", format: [dd, mm, yyyy])
],

// dd-mm-yyyy

or

inputFormatters:  <TextInputFormatter>[
DateTextInputFormatter( format: [dd, mm, yyyy])
],

// dd/mm/yyyy

[0.0.1] - 27/03/2020 #

  • Added DateTextInputFormatter widget
  • Initial release

[0.0.2] - 27/03/2020 #

  • Added example
  • Updated readme

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:date_text_input_formatter/date_text_input_formatter.dart';
import 'package:flutter/services.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      theme: ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: MyHomePage(title: 'Date Text Input Formatter'),
    );
  }
}

class MyHomePage extends StatefulWidget {
  MyHomePage({Key key, this.title}) : super(key: key);

  final String title;

  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  TextEditingController _controller = TextEditingController();

  @override
  void initState() {
    _controller = TextEditingController();
    super.initState();
  }

  @override
  void dispose() {
    _controller.dispose();
    super.dispose();
  }

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text(widget.title),
      ),
      body: Center(
        child: Padding(
          padding: const EdgeInsets.all(35.0),
          child: TextField(
            controller: _controller,
            keyboardType: TextInputType.datetime,
            decoration: InputDecoration(
              border: OutlineInputBorder(
                borderRadius: BorderRadius.circular(10.0),
              ),
              labelText: "Date",
              hintText: "25-11-2001",
            ),
            inputFormatters: <TextInputFormatter>[
              DateTextInputFormatter(delimiter: "-", format: [dd, mm, yyyy])
            ],
          ),
        ),
      ),
      floatingActionButton: FloatingActionButton(
        child: Icon(Icons.clear),
        onPressed: () => setState(() => _controller.clear()),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  date_text_input_formatter: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:date_text_input_formatter/date_text_input_formatter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
46
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
71
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • date_text_input_formatter that is a package requiring null.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test