data_validator 1.0.1

Dart native js
Flutter Android iOS web

A validation for all kinds of data that are typicaly used in the code.

data_validator #

A simple data validation

Getting Started #

In your project add the dependency:

dependencies:
  ...
  data_validator: any

Usage example #

import 'package:data_validator/data_validator.dart';
import 'package:data_validator/data_validator.dart';

void main() {
  print('running');
  print(DataValidator.isEmail("john@abc.com"));
  print(DataValidator.isPhoneNumber("9841580604"));
  print(DataValidator.isURL("https://www.google.com"));
  print(DataValidator.isFloat("4.5"));
  print(DataValidator.isIP("127.0.0.1"));
  print(DataValidator.toBoolean('true'));
  print(DataValidator.isJSON('{"name" : "John Doe"}'));
}


0
likes
100
pub points
53%
popularity

A validation for all kinds of data that are typicaly used in the code.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

nishantsubedi1996@gmail.com

License

MIT (LICENSE)

More

Packages that depend on data_validator