dartscord 1.0.3

  • Readme
  • Changelog
  • Installing
  • new40

A simple command-line application.

Created from templates made available by Stagehand under a BSD-style license.

1.0.0 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dartscord: ^1.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dartscord/dartscord.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
16
Health:
Code health derived from static analysis. [more]
75
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
40
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Package not compatible with runtime flutter-web on web

Because of the import of dart:io via the import chain package:dartscord/dartscord.dartdart:io

Package not compatible with runtime web

Because of the import of dart:io via the import chain package:dartscord/dartscord.dartdart:io

Health suggestions

Fix lib/src/events/guild.dart. (-8.63 points)

Analysis of lib/src/events/guild.dart reported 18 hints, including:

line 12 col 7: DO use curly braces for all flow control structures.

line 15 col 7: DO use curly braces for all flow control structures.

line 15 col 39: Unnecessary new keyword.

line 35 col 37: Unnecessary new keyword.

line 49 col 42: Unnecessary new keyword.

Fix lib/src/events/message.dart. (-7.71 points)

Analysis of lib/src/events/message.dart reported 16 hints, including:

line 21 col 19: Unnecessary new keyword.

line 38 col 19: Unnecessary new keyword.

line 40 col 9: Unnecessary new keyword.

line 58 col 49: Unnecessary new keyword.

line 60 col 19: Unnecessary new keyword.

Fix lib/src/client.dart. (-6.78 points)

Analysis of lib/src/client.dart reported 14 hints, including:

line 35 col 21: Unnecessary new keyword.

line 160 col 20: Unnecessary new keyword.

line 217 col 7: DO use curly braces for all flow control structures.

line 232 col 7: DO use curly braces for all flow control structures.

line 269 col 9: Unnecessary new keyword.

Fix additional 17 files with analysis or formatting issues. (-30.57 points)

Additional issues in the following files:

  • lib/src/objects/channel.dart (12 hints)
  • lib/src/events/channel.dart (10 hints)
  • lib/src/networking.dart (9 hints)
  • lib/src/event.dart (5 hints)
  • lib/src/objects/guild.dart (4 hints)
  • lib/src/objects/user.dart (4 hints)
  • lib/src/objects/game.dart (3 hints)
  • lib/src/objects/message.dart (3 hints)
  • lib/src/objects/overwrite.dart (3 hints)
  • lib/src/objects/emoji.dart (2 hints)
  • lib/src/objects/invite.dart (2 hints)
  • lib/src/objects/role.dart (2 hints)
  • lib/src/objects/webhook.dart (2 hints)
  • lib/src/objects/embed.dart (1 hint)
  • lib/dartscord.dart (Run dartfmt to format lib/dartscord.dart.)
  • lib/src/enums.dart (Run dartfmt to format lib/src/enums.dart.)
  • lib/src/object.dart (Run dartfmt to format lib/src/object.dart.)

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://www.tbias25.de was unreachable.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and dartscord.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
http ^0.12.1 0.12.1
path ^1.6.0 1.7.0
Transitive dependencies
charcode 1.1.3
collection 1.14.13
http_parser 3.1.4
meta 1.1.8
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0
Dev dependencies
pedantic ^1.8.0 1.9.0 1.9.1