dartprompt_sg 0.0.1
dartprompt_sg: ^0.0.1 copied to clipboard

for implementing library

0
likes
60/ 130
pub points
0%
popularity

We analyzed this package on Sep 17, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

README.md is empty.

The README.md file should inform others about your project, what it does, and how they can use it. See: the example generated by stagehand.

0/5 points: Provide a valid CHANGELOG.md

CHANGELOG.md is empty.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 11 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dartprompt_sg/dartprompt_sg.dart that imports:
  • package:dartprompt_sg/src/prompter.dart that imports:
  • package:dartprompt_sg/src/terminal.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run dart pub outdated: dart pub get failed:
ERR:
pubspec.yaml has no lower-bound SDK constraint.
You should edit pubspec.yaml to contain an SDK constraint:

environment:
  sdk: '>=2.10.0 <3.0.0'

See https://dart.dev/go/sdk-constraint

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `<3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.1+1, Dart 2.14.1.

0
likes
60
pub points
0%
popularity

for implementing library

Homepage

Documentation

API reference

License

unknown (LICENSE)

More

Packages that depend on dartprompt_sg