dart_pact_consumer 0.1.0
dart_pact_consumer: ^0.1.0 copied to clipboard

A consumer library to build and test pact contracts.

3
likes
30/ 130
pub points
49%
popularity

We analyzed this package on Sep 22, 2021, and awarded it 30 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Sdk-constraint doesn't allow future stable dart 2.x releases

pubspec.yaml:7:8

  ╷
7 │   sdk: '>=2.10.4 <2.12.0'
  │        ^^^^^^^^^^^^^^^^^^
  ╵
The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • Failed to resolve dependencies.
stdout: MSG : Resolving dependencies...

stderr: FINE: Pub 2.14.1
SLVR: fact: dart_pact_consumer is 0.1.0
SLVR: derived: dart_pact_consumer
SLVR: fact: dart_pact_consumer requires SDK version >=2.10.4 <2.12.0
SLVR: conflict: dart_pact_consumer requires SDK version >=2.10.4 <2.12.0
SLVR: Version solving took 0:00:00.042458 seconds.
    | Tried 1 solutions.
FINE: Resolving dependencies finished (0.056s).
ERR : The current Dart SDK version is 2.14.1.
    | 
    | Because dart_pact_consumer requires SDK version >=2.10.4 <2.12.0, version solving failed.
FINE: Exception type: SolveFailure
FINE: package:pub/src/solver/version_solver.dart 310:5               VersionSolver._resolveConflict
    | package:pub/src/solver/version_solver.dart 131:27              VersionSolver._propagate
    | package:pub/src/solver/version_solver.dart 95:11               VersionSolver.solve.<fn>
    | ===== asynchronous gap ===========================
    | dart:async                                                     Future.catchError
    | package:pub/src/utils.dart 112:52                              captureErrors.wrappedCallback
    | package:stack_trace                                            Chain.capture
    | package:pub/src/utils.dart 125:11                              captureErrors
[...]
    | Because dart_pact_consumer requires SDK version >=2.10.4 <2.12.0, version solving failed.
FINE: Exception type: SolveFailure
FINE: package:pub/src/solver/version_solver.dart 310:5               VersionSolver._resolveConflict
    | package:pub/src/solver/version_solver.dart 131:27              VersionSolver._propagate
    | package:pub/src/solver/version_solver.dart 95:11               VersionSolver.solve.<fn>
    | ===== asynchronous gap ===========================
    | dart:async                                                     Future.catchError
    | package:pub/src/utils.dart 112:52                              captureErrors.wrappedCallback
    | package:stack_trace                                            Chain.capture
    | package:pub/src/utils.dart 125:11                              captureErrors
    | package:pub/src/command.dart 168:13                            PubCommand.run
    | package:args/command_runner.dart 209:27                        CommandRunner.runCommand
    | package:dartdev/dartdev.dart 202:30                            DartdevRunner.runCommand
    | package:args/command_runner.dart 119:25                        CommandRunner.run.<fn>
    | dart:async                                                     new Future.sync
    | package:args/command_runner.dart 119:14                        CommandRunner.run
    | package:dartdev/dartdev.dart 54:29                             runDartdev
    | /b/s/w/ir/cache/builder/sdk/pkg/dartdev/bin/dartdev.dart 11:9  main
---- End log transcript ----

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run dart pub get for more information.

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

bin/github_download.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/dart_pact_consumer.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
0 / 20

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 2.14.1. Cannot run `dart pub outdated`.

pubspec.yaml:7:8

  ╷
7 │   sdk: '>=2.10.4 <2.12.0'
  │        ^^^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 2.14.1.

pubspec.yaml:7:8

  ╷
7 │   sdk: '>=2.10.4 <2.12.0'
  │        ^^^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

Support sound null safety
0 / 20

0/20 points: Unable to detect null safety

Package resolution failed. Could not determine null safety.

Run dart pub get for more information.

Analysed with Pana 0.21.1+1, Dart 2.14.1.