dart_math 0.0.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 18

DartMath #

A simple dart Math Library #

0.0.1 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dart_math: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dart_math/dart_math.dart';
  
Version Uploaded Documentation Archive
0.0.9+3 Dec 26, 2018 Go to the documentation of dart_math 0.0.9+3 Download dart_math 0.0.9+3 archive
0.0.9+2 Dec 26, 2018 Go to the documentation of dart_math 0.0.9+2 Download dart_math 0.0.9+2 archive
0.0.9+1 Dec 26, 2018 Go to the documentation of dart_math 0.0.9+1 Download dart_math 0.0.9+1 archive
0.0.9 Aug 25, 2018 Go to the documentation of dart_math 0.0.9 Download dart_math 0.0.9 archive
0.0.8 Aug 25, 2018 Go to the documentation of dart_math 0.0.8 Download dart_math 0.0.8 archive
0.0.7 Aug 23, 2018 Go to the documentation of dart_math 0.0.7 Download dart_math 0.0.7 archive
0.0.6 Aug 21, 2018 Go to the documentation of dart_math 0.0.6 Download dart_math 0.0.6 archive
0.0.5 Aug 21, 2018 Go to the documentation of dart_math 0.0.5 Download dart_math 0.0.5 archive
0.0.4 Aug 21, 2018 Go to the documentation of dart_math 0.0.4 Download dart_math 0.0.4 archive
0.0.3 Aug 21, 2018 Go to the documentation of dart_math 0.0.3 Download dart_math 0.0.3 archive

All 12 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
35
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
18
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0