darksky_weather 1.1.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 73

darksky_weather #

A dart library for interfacing with the Dark Sky Weather API.

Usage #

A simple usage example:

import 'dart:async';
import 'package:darksky_weather/darksky_weather_io.dart';

Future<Null> main() async {
  var darksky = new DarkSkyWeather("API_KEY_HERE",
      language: Language.German, units: Units.SI);
  var forecast = await darksky.getForecast(48.21, 16.363);

  print(forecast.currently.temperature);
  print(forecast.currently.summary);
}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

1.1.0 #

  • add tests
  • make pub analyzer happy

1.0.0 #

0.1.1 #

  • fix deserialisation issues
  • fix readme
  • refactor code and add options

0.1.0 #

  • first version of the api implementation

0.0.1 #

  • initial version

example/example.dart

// Copyright (c) 2017, 'rinukkusu'. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'dart:async';
import 'package:darksky_weather/darksky_weather_io.dart';

Future<Null> main() async {
  var darksky = new DarkSkyWeather("API_KEY_HERE",
      language: Language.German, units: Units.SI);
  var forecast = await darksky.getForecast(48.21, 16.363);

  print(forecast.currently.temperature);
  print(forecast.currently.summary);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  darksky_weather: ^1.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:darksky_weather/darksky_weather_browser.dart';
import 'package:darksky_weather/darksky_weather_browser.g.dart';
import 'package:darksky_weather/darksky_weather_io.dart';
import 'package:darksky_weather/darksky_weather_io.g.dart';
  
Version Uploaded Documentation Archive
1.2.0 Apr 6, 2019 Go to the documentation of darksky_weather 1.2.0 Download darksky_weather 1.2.0 archive
1.1.0 Nov 21, 2018 Go to the documentation of darksky_weather 1.1.0 Download darksky_weather 1.1.0 archive
0.1.1 May 24, 2017 Go to the documentation of darksky_weather 0.1.1 Download darksky_weather 0.1.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
56
Health:
Code health derived from static analysis. [more]
83
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
73
Learn more about scoring.

We analyzed this package on May 8, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.0
  • pana: 0.12.15

Platforms

Detected platforms: web

Platform components identified in package: html.

Health suggestions

Fix lib/src/models/datapoint.dart. (-10.89 points)

Analysis of lib/src/models/datapoint.dart reported 23 hints, including:

line 6 col 3: Prefer using /// for doc comments.

line 18 col 3: Prefer using /// for doc comments.

line 32 col 3: Prefer using /// for doc comments.

line 38 col 3: Prefer using /// for doc comments.

line 46 col 3: Prefer using /// for doc comments.

Fix lib/src/models/datablock.dart. (-3.45 points)

Analysis of lib/src/models/datablock.dart reported 7 hints, including:

line 9 col 3: Prefer using /// for doc comments.

line 16 col 1: Prefer using /// for doc comments.

line 22 col 3: Prefer using /// for doc comments.

line 33 col 1: Prefer using /// for doc comments.

line 39 col 3: Prefer using /// for doc comments.

Fix lib/src/models/forecast.dart. (-2.48 points)

Analysis of lib/src/models/forecast.dart reported 5 hints:

line 13 col 3: Prefer using /// for doc comments.

line 20 col 3: Prefer using /// for doc comments.

line 26 col 3: Prefer using /// for doc comments.

line 32 col 3: Prefer using /// for doc comments.

line 38 col 3: Prefer using /// for doc comments.

Fix lib/src/enums/units_enum.dart. (-0.50 points)

Analysis of lib/src/enums/units_enum.dart reported 1 hint:

line 12 col 3: Prefer using /// for doc comments.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
http ^0.12.0 0.12.0+2
json_annotation ^2.0.0 2.2.0
Transitive dependencies
async 2.2.0
charcode 1.1.2
collection 1.14.11
http_parser 3.1.3
meta 1.1.7
path 1.6.2
pedantic 1.6.0
source_span 1.5.5
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
build_runner ^1.1.2
json_serializable ^2.0.0
test ^1.3.0