custom_phone_number_package_v3 0.0.1
custom_phone_number_package_v3: ^0.0.1

Flutter Android iOS web

Custom phone number package

0
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Dec 4, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 17 API elements (5.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: PhoneNumber.validator

lib/custom_phone_number_package_v3.dart:6:7

  ╷
6 │ class PhoneNumber extends StatefulWidget {
  │       ^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/custom_phone_number_package_v3.dart

INFO: This method overrides a method annotated as '@mustCallSuper' in 'State', but doesn't invoke the overridden method.

lib/custom_phone_number_package_v3.dart:32:8

   ╷
32 │   void initState() {
   │        ^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/custom_phone_number_package_v3.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
country_code_picker^1.1.11.6.21.6.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
modal_bottom_sheet-1.0.1-dev1.0.1-dev
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs