currency v0.0.5 #
This is a simple package to help working with currencies in dart.
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: currency: ^0.0.5
2. Install it
You can install packages from the command line:
$ pub get
$ flutter pub get
Alternatively, your editor might support
pub get or
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Oct 7, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.5.1
- pana: 0.12.21
Detected platforms: Flutter, web, other
No platform restriction found in primary library
lib/currency.dart. (-4.89 points)
lib/currency.dart reported 10 hints, including:
line 65 col 22: DO use curly braces for all flow control structures.
line 80 col 31: DO use curly braces for all flow control structures.
line 81 col 36: DO use curly braces for all flow control structures.
line 82 col 14: DO use curly braces for all flow control structures.
line 89 col 23: DO use curly braces for all flow control structures.
Maintenance issues and suggestions
Provide a file named
CHANGELOG.md. (-20 points)
Changelog entries help developers follow the progress of your package. See the example generated by
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
currency.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
Package is pre-v0.1 release. (-10 points)
While nothing is inherently wrong with versions of
0.0.*, it might mean that the author is still experimenting with the general direction of the API.
|Dart SDK||>=2.0.0-dev.48 <3.0.0|