cupertino_localizations 1.0.0+1

  • Readme
  • Changelog
  • Example
  • Installing
  • 53

cupertino_localizations #

Provider localization for cupertino. just en,ar and zh if you don't wont to use the default. You can use it to fixed the error: The getter 'pasteButtonLabel' was called on null.

Usage #

MaterialApp(
  locale: Locale('ar', ''),
  localizationsDelegates: [
    GlobalCupertinoLocalizations.delegate,
    GlobalMaterialLocalizations.delegate,
    GlobalWidgetsLocalizations.delegate,
  ],
  supportedLocales: [
    const Locale('zh', 'CH'),
    const Locale('ar', ''),
    const Locale('en', 'US'),
  ],
 ...
}

Contributing #

Feel free to send me a pull request to add your langage.

Acknowledgment #

This library base on the work of crazy365966834 thank you.

1.0.0+1 #

  • Fix Readme and exmaple main.dart

1.0.0 #

  • Added the example.
  • First Relase.

0.0.2+1 #

  • Fix Readme

0.0.2 #

  • Fix Error and update readme.

0.0.1 #

  • Initial release

example/README.md

cupertino localizations example #

This is a flutter project to show you how you can use cupertion localization example to fix the issue with the selection and clipborad in IOS.

Getting Started #

  • open the terminal.
  • clone this project.
  • cd to it
  • connect your IOS device.
  • run flutter run
  • change the language of your app and selected a text you will notice .

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  cupertino_localizations: ^1.0.0+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:cupertino_localizations/cupertino_localizations.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
78
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
53
Learn more about scoring.

We analyzed this package on Jan 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter pub upgrade failed with the following output:

ERR: Because cupertino_localizations depends on flutter_localizations any from sdk which depends on intl 0.16.0, intl 0.16.0 is required.
 So, because cupertino_localizations depends on intl ^0.15.8, version solving failed.

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0