cupertino_localizations 1.0.0+1

  • Readme
  • Changelog
  • Example
  • Installing
  • 84

cupertino_localizations #

Provider localization for cupertino. just en,ar and zh if you don't wont to use the default. You can use it to fixed the error: The getter 'pasteButtonLabel' was called on null.

Usage #

  locale: Locale('ar', ''),
  localizationsDelegates: [
  supportedLocales: [
    const Locale('zh', 'CH'),
    const Locale('ar', ''),
    const Locale('en', 'US'),

Contributing #

Feel free to send me a pull request to add your langage.

Acknowledgment #

This library base on the work of crazy365966834 thank you.

1.0.0+1 #

  • Fix Readme and exmaple main.dart

1.0.0 #

  • Added the example.
  • First Relase.

0.0.2+1 #

  • Fix Readme

0.0.2 #

  • Fix Error and update readme.

0.0.1 #

  • Initial release


cupertino localizations example #

This is a flutter project to show you how you can use cupertion localization example to fix the issue with the selection and clipborad in IOS.

Getting Started #

  • open the terminal.
  • clone this project.
  • cd to it
  • connect your IOS device.
  • run flutter run
  • change the language of your app and selected a text you will notice .

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  cupertino_localizations: ^1.0.0+1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:cupertino_localizations/cupertino_localizations.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Oct 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (intl).


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
flutter_localizations 0.0.0
intl ^0.15.8 0.15.8 0.16.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
path 1.6.4
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies