Provider localization for cupertino. just en,ar and zh if you don't wont to use the default. You can use it to fixed the error: The getter 'pasteButtonLabel' was called on null.
MaterialApp( locale: Locale('ar', ''), localizationsDelegates: [ GlobalCupertinoLocalizations.delegate, GlobalMaterialLocalizations.delegate, GlobalWidgetsLocalizations.delegate, ], supportedLocales: [ const Locale('zh', 'CH'), const Locale('ar', ''), const Locale('en', 'US'), ], ... }
Feel free to send me a pull request to add your langage.
This library base on the work of crazy365966834 thank you.
- Fix Readme and exmaple main.dart
- Added the example.
- First Relase.
- Fix Readme
- Fix Error and update readme.
- Initial release
cupertino localizations example #
This is a flutter project to show you how you can use cupertion localization example to fix the issue with the selection and clipborad in IOS.
Getting Started #
- open the terminal.
- clone this project.
- cd to it
- connect your IOS device.
- change the language of your app and selected a text you will notice .
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: cupertino_localizations: ^1.0.0+1
2. Install it
You can install packages from the command line:
$ pub get
$ flutter pub get
Alternatively, your editor might support
pub get or
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jan 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.7.0
- pana: 0.13.4
- Flutter: 1.12.13+hotfix.5
Analysis issues and suggestions
Fix dependencies in
flutter pub upgrade failed with the following output:
ERR: Because cupertino_localizations depends on flutter_localizations any from sdk which depends on intl 0.16.0, intl 0.16.0 is required. So, because cupertino_localizations depends on intl ^0.15.8, version solving failed.
Maintenance issues and suggestions
No valid SDK. (-20 points)
The analysis could not detect a valid SDK that can use this package.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=2.1.0 <3.0.0|