cumo_transer 0.1.1
cumo_transer: ^0.1.1 copied to clipboard

Constructor of UMD Object-Style-Element, of Universal MarkDown Format

0
likes
40/ 130
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 40 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

README.md is empty.

The README.md file should inform others about your project, what it does, and how they can use it. See: the example generated by stagehand.

0/5 points: Provide a valid CHANGELOG.md

CHANGELOG.md is empty.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • Failed to resolve dependencies.
stdout: MSG : Resolving dependencies...

stderr: FINE: Pub 2.15.0-268.18.beta
SLVR: fact: cumo_transer is 0.1.1
SLVR: derived: cumo_transer
SLVR: fact: cumo_transer requires SDK version >=2.15.0 <3.0.0
SLVR: conflict: cumo_transer requires SDK version >=2.15.0 <3.0.0
SLVR: Version solving took 0:00:00.042890 seconds.
    | Tried 1 solutions.
FINE: Resolving dependencies finished (0.068s).
ERR : The current Dart SDK version is 2.15.0-268.18.beta.
    | 
    | Because cumo_transer requires SDK version >=2.15.0 <3.0.0, version solving failed.
FINE: Exception type: SolveFailure
FINE: package:pub/src/solver/version_solver.dart 312:5               VersionSolver._resolveConflict
    | package:pub/src/solver/version_solver.dart 133:27              VersionSolver._propagate
    | package:pub/src/solver/version_solver.dart 97:11               VersionSolver.solve.<fn>
    | ===== asynchronous gap ===========================
    | dart:async                                                     Future.catchError
    | package:pub/src/utils.dart 109:52                              captureErrors.wrappedCallback
    | package:stack_trace                                            Chain.capture
    | package:pub/src/utils.dart 122:11                              captureErrors
[...]
    | Because cumo_transer requires SDK version >=2.15.0 <3.0.0, version solving failed.
FINE: Exception type: SolveFailure
FINE: package:pub/src/solver/version_solver.dart 312:5               VersionSolver._resolveConflict
    | package:pub/src/solver/version_solver.dart 133:27              VersionSolver._propagate
    | package:pub/src/solver/version_solver.dart 97:11               VersionSolver.solve.<fn>
    | ===== asynchronous gap ===========================
    | dart:async                                                     Future.catchError
    | package:pub/src/utils.dart 109:52                              captureErrors.wrappedCallback
    | package:stack_trace                                            Chain.capture
    | package:pub/src/utils.dart 122:11                              captureErrors
    | package:pub/src/command.dart 180:13                            PubCommand.run
    | package:args/command_runner.dart 209:27                        CommandRunner.runCommand
    | package:dartdev/dartdev.dart 227:30                            DartdevRunner.runCommand
    | package:args/command_runner.dart 119:25                        CommandRunner.run.<fn>
    | dart:async                                                     new Future.sync
    | package:args/command_runner.dart 119:14                        CommandRunner.run
    | package:dartdev/dartdev.dart 66:29                             runDartdev
    | /b/s/w/ir/cache/builder/sdk/pkg/dartdev/bin/dartdev.dart 11:9  main
---- End log transcript ----

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Tag detection failed.

Exception: Couldn't read pubspec.yaml in /C:/Users/takuy/AppData/Roaming/Pub/Cache/hosted/pub.dartlang.org/matrix2d-1.0.0. FileSystemException: Cannot open file, path = '/C:/Users/takuy/AppData/Roaming/Pub/Cache/hosted/pub.dartlang.org/matrix2d-1.0.0/pubspec.yaml' (OS Error: No such file or directory, errno = 2)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
0 / 20

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 2.15.0-268.18.beta. Cannot run `dart pub outdated`.

pubspec.yaml:7:8

  ╷
7 │   sdk: ">=2.15.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 2.15.0-268.18.beta.

pubspec.yaml:7:8

  ╷
7 │   sdk: ">=2.15.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Tag detection failed.

Exception: Couldn't read pubspec.yaml in /C:/Users/takuy/AppData/Roaming/Pub/Cache/hosted/pub.dartlang.org/matrix2d-1.0.0. FileSystemException: Cannot open file, path = '/C:/Users/takuy/AppData/Roaming/Pub/Cache/hosted/pub.dartlang.org/matrix2d-1.0.0/pubspec.yaml' (OS Error: No such file or directory, errno = 2)

For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.21.4, Dart 2.15.0-268.18.beta.

0
likes
40
pub points
0%
popularity

Publisher

dev-pack.org

Constructor of UMD Object-Style-Element, of Universal MarkDown Format

Repository (GitHub)
View/report issues

License

BSD-3-Clause (LICENSE)

Dependencies

matrix2d

More

Packages that depend on cumo_transer