csharp_parser 0.0.4

  • Readme
  • Changelog
  • Installing
  • 0

csharp_parser #

experimental C# parser done mostly to learn how to create parsers... based on awesome http://www.craftinginterpreters.com

Current main purpose is converting POCOs to PODOs (plain old C#/Dart object) files

Warning! It's not production ready

Usage #

var scanner = new Scanner(sourceCode);
print('is error: ${scanner.hadError}');
Parser parser = new Parser(scanner.tokens);
List<Stmt> statements = parser.parse();
//now statements contains AST tree

Features and bugs #

Recognizes namespace class, properties, methods

Current limitations #

  • ignores method bodies
  • does not support conditional expressions
  • does not support namespace aliases in using directive

Changelog #

0.0.2 #

  • ignore attributes

0.0.1 #

  • Initial version, created by Stagehand

0.0.4 #

  • Attributes on classes

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  csharp_parser: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:csharp_parser/csharp_parser.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0