crypto_tea 0.0.2
crypto_tea: ^0.0.2 copied to clipboard

A tea crypto for Dart libraries or applications.

55/ 130
pub points

We analyzed this package on Sep 16, 2021, and awarded it 55 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid

Links in `` should be secure. 1 link is insecure.

23 │ <p>Please file feature requests and bugs at the <a href="">issue tracker</a>.</p>
   │                                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Use https URLs instead.

5/5 points: Provide a valid

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/crypto_tea_example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 30 API elements (3.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js


  • package:crypto_tea/crypto_tea.dart that imports:
  • package:crypto_tea/src/crypto_tea.dart that imports:
  • package:crypto_tea/src/padding.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/crypto_tea.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version


To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.2` on hex does not support the stable version `0.2.0`.

Try running dart pub upgrade --major-versions hex to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.4.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.1+1, Dart 2.14.1.

pub points

A tea crypto for Dart libraries or applications.

Repository (GitHub)
View/report issues


API reference






Packages that depend on crypto_tea