couchdbclientfordart 0.0.3

Flutter Android iOS

A couch db client written for dart and flutter.

0
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Sep 23, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 56 out of 111 API elements (50.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:couchdbclientfordart/couchdbclientfordart.dart that imports:
  • package:couchdbclientfordart/engines/http/httpengine.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

INFO: This function has a return type of 'FutureOr

lib/engines/http/httpengine.dart:26:29

   ╷
26 │   Future<CompositeResponse> process(HttpMethod method, String inputUriString ,{Map<String, String> headers,String body, String localFilePathToPickUpFile, String localFilePathToSaveAttachment}) async{
   │                             ^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/engines/http/httpengine.dart

INFO: Name non-constant identifiers using lowerCamelCase.

lib/engines/uri/uriengine.dart:18:16

   ╷
18 │   static final db_parser = _getUriParser("/{db}");
   │                ^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/engines/uri/uriengine.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
http^0.12.0+20.12.20.12.2
uri^0.11.3+10.11.3+10.11.3+1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
charcode-1.1.31.1.3
collection-1.14.131.14.13
http_parser-3.1.43.1.4
matcher-0.12.90.12.9
meta-1.1.81.2.3
path-1.7.01.7.0
pedantic-1.9.01.9.2
quiver-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
utf-0.9.0+50.9.0+5
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
70
pub points
0%
popularity

A couch db client written for dart and flutter.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

anuragvohraec@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, http, uri

More

Packages that depend on couchdbclientfordart