convert 2.1.0

Conversion utilities package #

This package contains encoders and decoders for converting between different data representations. It's the external counterpart of the dart:convert core library, and contains less-central APIs and APIs that need more flexible versioning.

2.1.0 #

  • Added an IdentityCodec<T> which implements Codec<T,T> for use as default value for in functions accepting an optional Codec as parameter.

2.0.2 #

  • Set max SDK version to <3.0.0, and adjust other dependencies.

2.0.1 #

  • PercentEncoder no longer encodes digits. This follows the specified behavior.

2.0.0 #

Note: No new APIs have been added in 2.0.0. Packages that would use 2.0.0 as a lower bound should use 1.0.0 instead—for example, convert: ">=1.0.0 <3.0.0".

  • HexDecoder, HexEncoder, PercentDecoder, and PercentEncoder no longer extend ChunkedConverter.

1.1.1 #

  • Fix all strong-mode warnings.

1.1.0 #

  • Add AccumulatorSink, ByteAccumulatorSink, and StringAccumulatorSink classes for providing synchronous access to the output of chunked converters.

1.0.1 #

  • Small improvement in percent decoder efficiency.

1.0.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  convert: ^2.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:convert/convert.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
98
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
84
Overall:
Weighted score of the above. [more]
96
Learn more about scoring.

We analyzed this package on Sep 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:convert/convert.dart.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and convert.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

The package description is too short. (-6 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.17.0 <3.0.0
charcode ^1.1.0 1.1.2
typed_data ^1.1.0 1.1.6
Dev dependencies
test >=0.12.0 <2.0.0