convert 1.1.1

  • Readme
  • Changelog
  • Installing
  • --

Conversion utilities package #

This package contains encoders and decoders for converting between different data representations. It's the external counterpart of the dart:convert core library, and contains less-central APIs and APIs that need more flexible versioning.

1.1.1 #

  • Fix all strong-mode warnings.

1.1.0 #

  • Add AccumulatorSink, ByteAccumulatorSink, and StringAccumulatorSink classes for providing synchronous access to the output of chunked converters.

1.0.1 #

  • Small improvement in percent decoder efficiency.

1.0.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  convert: ^1.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:convert/convert.dart';
  
Awaiting analysis to complete.