All notable changes to this project will be documented in this file.
Add this to your package's pubspec.yaml file:
dependencies: conreality: ^0.0.3
You can install packages from the command line:
$ pub get
$ flutter pub get
Alternatively, your editor might support
pub get or
flutter pub get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.0.3||Nov 3, 2018|
|0.0.2||Oct 5, 2018|
|0.0.1||Oct 5, 2018|
|0.0.0||Oct 5, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jun 24, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter, web, other
No platform restriction found in primary library
Document public APIs. (-1 points)
1 out of 1 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.
Support latest dependencies. (-25 points)
The version constraint in
pubspec.yaml does not support the latest published versions for 3 dependencies (2 direct:
Homepage URL doesn't exist. (-20 points)
At the time of the analysis the
https://sdk.conreality.org/dart/ was unreachable.
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Package is pre-v0.1 release. (-10 points)
While nothing is inherently wrong with versions of
0.0.*, it might mean that the author is still experimenting with the general direction of the API.
Maintain an example.
None of the files in the package's
example/ directory matches known example patterns.
Common filename patterns include
conreality.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
|Dart SDK||>=2.0.0 <3.0.0|