config_generator 0.1.0
config_generator: ^0.1.0 copied to clipboard

Dart native

Generate implementation of config classes from build.yaml configuration

1
likes
60 / 110
pub points
0 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:config_generator/config_generator.dart that imports:
  • package:config_generator/src/config_generator_base.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/task/dart.dart that imports:
  • package:analyzer/src/task/strong_mode.dart that imports:
  • package:analyzer/src/summary/link.dart that imports:
  • package:analyzer/src/summary/resynthesize.dart that imports:
  • package:analyzer/src/summary/summary_sdk.dart that imports:
  • package:analyzer/src/summary/package_bundle_reader.dart that imports:
  • package:analyzer/src/task/api/model.dart that imports:
  • package:analyzer/src/task/model.dart that imports:
  • package:analyzer/src/generated/engine.dart that imports:
  • package:analyzer/error/listener.dart that imports:
  • package:front_end/src/fasta/fasta_codes.dart that imports:
  • package:front_end/src/fasta/kernel/type_labeler.dart that imports:
  • package:front_end/src/fasta/problems.dart that imports:
  • package:front_end/src/fasta/messages.dart that imports:
  • package:front_end/src/fasta/compiler_context.dart that imports:
  • package:front_end/src/fasta/colors.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: Use isNotEmpty instead of length

lib/src/config_generator_base.dart:37:25

   ╷
37 │     var allReferences = classMap.length > 0
   │                         ^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/config_generator_base.dart

INFO: Use isEmpty instead of length

lib/src/config_generator_base.dart:45:9

   ╷
45 │     if (top.length == 0) {
   │         ^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/config_generator_base.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.33.3 <0.35.00.34.31.1.0
build^1.0.01.1.01.6.3
code_builder^3.1.33.6.03.6.0
source_gen^0.9.00.9.4+10.9.10+3
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.02.0.0
async-2.5.02.5.0
built_collection-5.0.05.0.0
built_value-8.0.08.0.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
csslib-0.17.00.17.0
dart_style-1.2.31.3.14
file-5.2.16.1.0
fixnum-1.0.01.0.0
front_end-0.1.9+10.1.29
glob-1.2.02.0.0
html-0.15.00.15.0
intl-0.17.00.17.0
js-0.6.30.6.3
kernel-0.3.9+10.3.29
matcher-0.12.100.12.10
meta-1.3.01.3.0
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
plugin-0.2.0+30.2.0+3
pub_semver-1.4.42.0.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.33.3 <0.35.0` on analyzer does not support the stable version `0.35.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Dart 2.12.0.

1
likes
60
pub points
0%
popularity

Generate implementation of config classes from build.yaml configuration

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

steen@varsted.dk

License

BSD (LICENSE)

Dependencies

analyzer, build, code_builder, source_gen

More

Packages that depend on config_generator