A new Flutter package for call Api using http.
Getting Started #
This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.
For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.
[0.0.2] - 11-10-2019
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: communication_handler: ^0.0.2
2. Install it
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jan 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.7.0
- pana: 0.13.4
- Flutter: 1.12.13+hotfix.5
Health issues and suggestions
Document public APIs. (-1 points)
13 out of 13 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.
lib/communication_handler.dart. (-3.45 points)
lib/communication_handler.dart reported 7 hints, including:
line 3 col 8: Unused import: 'dart:convert'.
line 4 col 8: Unused import: 'dart:convert'.
line 13 col 3: Name non-constant identifiers using lowerCamelCase.
line 26 col 3: Name non-constant identifiers using lowerCamelCase.
line 55 col 3: Name non-constant identifiers using lowerCamelCase.
Maintenance issues and suggestions
Homepage URL doesn't exist. (-20 points)
At the time of the analysis the
https://github.com/kevinsojitra/Flutter-Communication was unreachable.
Support latest dependencies. (-10 points)
The version constraint in
pubspec.yaml does not support the latest published versions for 1 dependency (
The package description is too short. (-14 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
communication_handler.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
Package is pre-v0.1 release. (-10 points)
While nothing is inherently wrong with versions of
0.0.*, it might mean that the author is still experimenting with the general direction of the API.
|Dart SDK||>=2.1.0 <3.0.0|