common 1.0.0+7

commondart #

1.0.0+7 #

  • Nothing Update

1.0.0 #

import 'package:common/hashid.dart';
import 'package:common/util.dart';


HashIds hashids = HashIds(salt: "secret")
String output = hashids.encode(123);
bool isInDebugMode = Util().isInDebugMode;
Color c = HexColor.create("#ff0000");

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  common: ^1.0.0+7

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:common/colors.dart';
import 'package:common/hashid.dart';
import 'package:common/util.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
30
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
57
Learn more about scoring.

We analyzed this package on Sep 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/hashid.dart.

Run flutter format to format lib/hashid.dart.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/nayzawoo/commondart was unreachable.

Documentation URL isn't helpful. (-10 points)

Either remove the documentation field from pubspec.yaml, or update it to link to a website about the package.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and common.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
async >=1.10.0 <3.0.0 2.3.0
flutter 0.0.0
http ^0.12.0+2 0.12.0+2
Transitive dependencies
charcode 1.1.2
collection 1.14.11 1.14.12
http_parser 3.1.3
meta 1.1.7
path 1.6.4
pedantic 1.8.0+1
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
test ^1.3.0